Бан при попытке брутфорса Mikrotik

Простая, но эффективная защита от желающих получить несанкционированный доступ над Mikrotik’ом:
 

1. FTP. После 10-го неудачного залогинивания — бан на 3 часа:

 
/ip firewall filter
 
add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop 
comment="drop ftp brute forcers"

add chain=output action=accept protocol=tcp content="530 Login incorrect" dst-limit=1/1m,9,dst-address/1m

add chain=output action=add-dst-to-address-list protocol=tcp content="530 Login incorrect" 
address-list=ftp_blacklist address-list-timeout=3h

2. SSH. После третьего неудачного логина — бан айпишника на 10 дней:


 
/ip firewall filter

add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop 
comment="drop ssh brute forcers" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new 
src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist 
address-list-timeout=10d comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new 
src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3 
address-list-timeout=1m comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1 
action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list 
address-list=ssh_stage1 address-list-timeout=1m comment="" disabled=no 

Оригинал взят отсюда — http://wiki.mikrotik.com/wiki/Bruteforce_login_prevention_%28FTP_%26_SSH%29

  • Anonymous

    спасибо

  • вопрос на засыпку, а если у меня FTP на windows, он тоже банит или как это зделать?

    • Четно, не уверена что при пробросе портов правила для брутфорса будут работать. В крайнем случает — FTP можно защитить штатными средствами самого сервера.

    • Anonymous

      наверно по этому у меня этот финт и не получается )

  • Anonymous

    2. SSH. После третьего неудачного логина — бан айпишника на 10 дней<br />не совсем точно. после n-го логина (без разницы удачного или нет, главное нового) в течении 1 минуты — бан на 10 дней